$re = '/hsl\(\d{1,3}, +\d{1,2}%, +\d{1,2}%\)/';
$str = 'color: hsl(10, 3%, 19%);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);