// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/produto\/(.*)(.)(html)").unwrap();
let string = "https://atacadogames.com/produto/jogo-sword-art-497329.html
https://atacadogames.com/produto/carregador-usb-pikachu-446839.html
https://atacadogames.com/produto/jogo-arms-switch-419772.html
\\/produto\\/(.*)(.)(html)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}