package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/produto\/(.*)(.)(html)`)
var str = `https://atacadogames.com/produto/jogo-sword-art-497329.html
https://atacadogames.com/produto/carregador-usb-pikachu-446839.html
https://atacadogames.com/produto/jogo-arms-switch-419772.html
\/produto\/(.*)(.)(html)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}