re = /\/produto\/(.*)(.)(html)/m
str = 'https://atacadogames.com/produto/jogo-sword-art-497329.html
https://atacadogames.com/produto/carregador-usb-pikachu-446839.html
https://atacadogames.com/produto/jogo-arms-switch-419772.html
\\/produto\\/(.*)(.)(html)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end