$re = '/simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);/m';
$str = ' simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, {
type: "click",
target: "[data-test-id=filterMenu-author]",
});
';
$subst = "userEvent.$1(screen.getByTestId(\"$2\"))";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;