#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);"
Local $sString = " simulate(component, {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=filterMenu-owner]"," & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" simulate(component, {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=filterMenu-ownerUser]"," & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" simulate(filterMenuPopup, {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=filterMenu-author]"," & @CRLF & _
" });" & @CRLF & _
""
Local $sSubst = "userEvent.$1(screen.getByTestId("$2"))"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)