package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);`)
var str = ` simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, {
type: "click",
target: "[data-test-id=filterMenu-author]",
});
`
var substitution = "userEvent.$1(screen.getByTestId("$2"))"
fmt.Println(re.ReplaceAllString(str, substitution))
}