re = /(.+?(?=administrator)).*((?<=administrator[0-9]).*)/
str = '/home/clems/ftp.irt-conseil.com/administrator1/ca/index.php
/home/clems/ftp.irt-conseil.com/administrator2/index.php '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end