using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?(?=administrator)).*((?<=administrator[0-9]).*)";
string input = @"/home/clems/ftp.irt-conseil.com/administrator1/ca/index.php
/home/clems/ftp.irt-conseil.com/administrator2/index.php ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}