$re = '/(.+?(?=administrator)).*((?<=administrator[0-9]).*)/';
$str = '/home/clems/ftp.irt-conseil.com/administrator1/ca/index.php
/home/clems/ftp.irt-conseil.com/administrator2/index.php ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);