$re = '/[0-9]{2} ?([05][1-9]|[16][02]) ?(0[1-9]|[12][0-9]|3[0-1]) ?\/?[0-9]{3,4}/';
$str = '821206/0351
82 12 06 0351
721206 0351
82 82 23/3222
82 52 12/342
825212342
82 61 45 2222
821206 0351';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);