const regex = /[0-9]{2} ?([05][1-9]|[16][02]) ?(0[1-9]|[12][0-9]|3[0-1]) ?\/?[0-9]{3,4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{2} ?([05][1-9]|[16][02]) ?(0[1-9]|[12][0-9]|3[0-1]) ?\\\/?[0-9]{3,4}', 'g')
const str = `821206/0351
82 12 06 0351
721206 0351
82 82 23/3222
82 52 12/342
825212342
82 61 45 2222
821206 0351`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}