#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]{2} ?([05][1-9]|[16][02]) ?(0[1-9]|[12][0-9]|3[0-1]) ?\/?[0-9]{3,4}"
Local $sString = "821206/0351 " & @CRLF & _
"82 12 06 0351 " & @CRLF & _
"721206 0351 " & @CRLF & _
"82 82 23/3222 " & @CRLF & _
"82 52 12/342" & @CRLF & _
"825212342" & @CRLF & _
"82 61 45 2222" & @CRLF & _
"821206 0351"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")