re = /(ایران)?(\d{2})(?:-|,| )(\d{3})([ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]{1})(\d{2})/m
str = 'ایران48-279ع17
48-279ع17
ایران48,279ع17
48,279ع17
ایران48 279ع17
48 279ع17 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end