package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ایران)?(\d{2})(?:-|,| )(\d{3})([ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]{1})(\d{2})`)
var str = `ایران48-279ع17
48-279ع17
ایران48,279ع17
48,279ع17
ایران48 279ع17
48 279ع17 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}