const regex = /(ایران)?(\d{2})(?:-|,| )(\d{3})([ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]{1})(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ایران)?(\\d{2})(?:-|,| )(\\d{3})([ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]{1})(\\d{2})', 'gm')
const str = `ایران48-279ع17
48-279ع17
ایران48,279ع17
48,279ع17
ایران48 279ع17
48 279ع17 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}