const regex = /(https:\/\/)?(www\.)?(((discord(app)?)?\.com\/invite)|((discord(app)?)?\.gg))\/(?<invite>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/)?(www\\.)?(((discord(app)?)?\\.com\\\/invite)|((discord(app)?)?\\.gg))\\\/(?<invite>.+)', 'gm')
const str = `discord.gg/wwwww
.gg/gay
.com/invite/gay
discord.com/invite/ass
https://www.discord.com/invite/ass`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}