package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https:\/\/)?(www\.)?(((discord(app)?)?\.com\/invite)|((discord(app)?)?\.gg))\/(?<invite>.+)`)
var str = `discord.gg/wwwww
.gg/gay
.com/invite/gay
discord.com/invite/ass
https://www.discord.com/invite/ass`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}