import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/)?(www\\.)?(((discord(app)?)?\\.com\\/invite)|((discord(app)?)?\\.gg))\\/(?<invite>.+)";
final String string = "discord.gg/wwwww\n"
+ ".gg/gay\n"
+ ".com/invite/gay\n"
+ "discord.com/invite/ass\n"
+ "https://www.discord.com/invite/ass";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}