import Foundation
let pattern = #"\/(\d{1,})\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://mangadex.org/title/40103/yuusha-no-gawari-ni-maou-toubatsu-shitara-tegara-wo-yokodoroi-saremashita
https://mangadex.org/title/8487/yuusha-ni-narenakatta-ore-wa-shibushibu-shuushoku-o-ketsuishimashita
https://mangadex.org/title/661/toaru-kagaku-no-railgun
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)