const regex = /\/(\d{1,})\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(\\d{1,})\\\/', 'gm')
const str = `https://mangadex.org/title/40103/yuusha-no-gawari-ni-maou-toubatsu-shitara-tegara-wo-yokodoroi-saremashita
https://mangadex.org/title/8487/yuusha-ni-narenakatta-ore-wa-shibushibu-shuushoku-o-ketsuishimashita
https://mangadex.org/title/661/toaru-kagaku-no-railgun`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}