using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(\d{1,})\/";
string input = @"https://mangadex.org/title/40103/yuusha-no-gawari-ni-maou-toubatsu-shitara-tegara-wo-yokodoroi-saremashita
https://mangadex.org/title/8487/yuusha-ni-narenakatta-ore-wa-shibushibu-shuushoku-o-ketsuishimashita
https://mangadex.org/title/661/toaru-kagaku-no-railgun";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}