// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(8058|5899|5898|6010|6018|6014|6063)[0-9]{10,15}").unwrap();
let string = "8058996888285610
58996888285610";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}