re = /^(8058|5899|5898|6010|6018|6014|6063)[0-9]{10,15}/
str = '8058996888285610
58996888285610'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end