package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(8058|5899|5898|6010|6018|6014|6063)[0-9]{10,15}`)
var str = `8058996888285610
58996888285610`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}