re = /(\bVR\b)|(\bMA-DO\b)|(\bTUSSEN\b)|(\bTSS\b)|(\bOM\b)|(\bVOOR\b)|(\bTOT\b)|(\b\d{1,2}[HU.:*]\d{1,2}[U]\b)|(\b\d{1,2}[HU.:*]\d{1,2}\b)|(\b\d{1,2}[HU]\b)|(\bd{1,2}[HU]\b)/
str = 'LEVEREN ZONDER FOUT 25/08/2016 OM 8U REF. 090008865
LEVEREN ZONDER FOUT 24/08/2016 TSS 9U00 EN 11U00 REF:15453
LEVEREN TUSSEN 9.00-16.30 UUR
LEV TSS 9H-16H30/GEEN HEFTRUCK
LEV MA-DO 8H-16H30/VR 8H-12H30
LEVEREN ZONDER FOUT 12/09/2016 TUSSEN 09*00 EN 16*00 UUR
LEVEREN ZONDER FOUT 13/09/2016 OM 10*00U MET REF NR: 090009197
LEVEREN VOOR 15H00
LEV.MA-DO TOT 16H / VR TOT 14H TEST
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end