#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\bVR\b)|(\bMA-DO\b)|(\bTUSSEN\b)|(\bTSS\b)|(\bOM\b)|(\bVOOR\b)|(\bTOT\b)|(\b\d{1,2}[HU.:*]\d{1,2}[U]\b)|(\b\d{1,2}[HU.:*]\d{1,2}\b)|(\b\d{1,2}[HU]\b)|(\bd{1,2}[HU]\b)"
Local $sString = "LEVEREN ZONDER FOUT 25/08/2016 OM 8U REF. 090008865" & @CRLF & _
"LEVEREN ZONDER FOUT 24/08/2016 TSS 9U00 EN 11U00 REF:15453" & @CRLF & _
"LEVEREN TUSSEN 9.00-16.30 UUR" & @CRLF & _
"LEV TSS 9H-16H30/GEEN HEFTRUCK" & @CRLF & _
"LEV MA-DO 8H-16H30/VR 8H-12H30" & @CRLF & _
"LEVEREN ZONDER FOUT 12/09/2016 TUSSEN 09*00 EN 16*00 UUR" & @CRLF & _
"LEVEREN ZONDER FOUT 13/09/2016 OM 10*00U MET REF NR: 090009197" & @CRLF & _
"LEVEREN VOOR 15H00" & @CRLF & _
"LEV.MA-DO TOT 16H / VR TOT 14H TEST" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")