import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bVR\\b)|(\\bMA-DO\\b)|(\\bTUSSEN\\b)|(\\bTSS\\b)|(\\bOM\\b)|(\\bVOOR\\b)|(\\bTOT\\b)|(\\b\\d{1,2}[HU.:*]\\d{1,2}[U]\\b)|(\\b\\d{1,2}[HU.:*]\\d{1,2}\\b)|(\\b\\d{1,2}[HU]\\b)|(\\bd{1,2}[HU]\\b)";
final String string = "LEVEREN ZONDER FOUT 25/08/2016 OM 8U REF. 090008865\n"
+ "LEVEREN ZONDER FOUT 24/08/2016 TSS 9U00 EN 11U00 REF:15453\n"
+ "LEVEREN TUSSEN 9.00-16.30 UUR\n"
+ "LEV TSS 9H-16H30/GEEN HEFTRUCK\n"
+ "LEV MA-DO 8H-16H30/VR 8H-12H30\n"
+ "LEVEREN ZONDER FOUT 12/09/2016 TUSSEN 09*00 EN 16*00 UUR\n"
+ "LEVEREN ZONDER FOUT 13/09/2016 OM 10*00U MET REF NR: 090009197\n"
+ "LEVEREN VOOR 15H00\n"
+ "LEV.MA-DO TOT 16H / VR TOT 14H TEST\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}