import Foundation
let pattern = #"(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\s*([0-9]{2})(?:\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\s+|-)([0-9][0-9]([0-9][0-9])?)\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\s*(?:GMT)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Wed, 23-May-12 01:23:31 GMT
23-May-12 01:23:31 GMT
23-May-12 01:23:31
23 May 2012 01:23:31 GMT
23 May 2012 01:23:31 GMT
Wed, 23 May 2012 01:23:31 GMT
23 mAy 2012 01:23:31 GMT
23 maY 12 01:23:31
23 jan 12 22:23:31
01 AUG 12 15:23:31 GMT
01 bla 12 15:23:31 GMT
1 May 2012 15:23:31 GMT
01 May 2012 15:23:31 BLA
01 May 2012-15:23:31
01 May 2012-15/23:31
01 May 2012-15/23:31
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)