import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\\s*([0-9]{2})(?:\\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\\s+|-)([0-9][0-9]([0-9][0-9])?)\\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\\s*(?:GMT)?";
final String string = "Wed, 23-May-12 01:23:31 GMT \n"
+ "23-May-12 01:23:31 GMT \n"
+ "23-May-12 01:23:31 \n"
+ "23 May 2012 01:23:31 GMT \n"
+ "23 May 2012 01:23:31 GMT\n"
+ "Wed, 23 May 2012 01:23:31 GMT\n"
+ "23 mAy 2012 01:23:31 GMT\n"
+ "23 maY 12 01:23:31\n"
+ "23 jan 12 22:23:31\n"
+ "01 AUG 12 15:23:31 GMT\n\n"
+ "01 bla 12 15:23:31 GMT\n"
+ "1 May 2012 15:23:31 GMT\n"
+ "01 May 2012 15:23:31 BLA\n"
+ "01 May 2012-15:23:31\n"
+ "01 May 2012-15/23:31\n"
+ "01 May 2012-15/23:31";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}