// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*) ([\w\d\.\-\(\)]+) (\d(?:\.\d+){2,}$)").unwrap();
let string = "id-DirectTrust. arc 1.3.6.1.4.1.41179
id-DirectTrustpolicies id-DirectTrust.(0) 1.3.6.1.4.1.41179.0
DirectTrust-CP 2.0 id-DirectTrustpolicies.(2.0) 1.3.6.1.4.1.41179.0.2.0
id-DirectTrust-LoAs id-DirectTrust.(1) 1.3.6.1.4.1.41179.1
DirectTrust ID LoA 1 id-DirectTrust-LoAs.(1) 1.3.6.1.4.1.41179.1.1
DirectTrust ID LoA 2 id-DirectTrust-LoAs.(2) 1.3.6.1.4.1.41179.1.2
DirectTrust ID LoA 3 id-DirectTrust-LoAs.(3) 1.3.6.1.4.1.41179.1.3
DirectTrust ID LoA 4 id-DirectTrust-LoAs.(4) 1.3.6.1.4.1.41179.1.4
DirectTrust ID IAL 1 id-DirectTrust-LoAs.(1) 1.3.6.1.4.1.41179.1.1
DirectTrust ID IAL 2 id-DirectTrust-LoAs.(5) 1.3.6.1.4.1.41179.1.5
DirectTrust ID IAL 3 id-DirectTrust-LoAs.(6) 1.3.6.1.4.1.41179.1.6
id-DirectTrust-Cat id-DirectTrust.(2) 1.3.6.1.4.1.41179.2
DirectTrust CE id-DirectTrust-Cat.(1) 1.3.6.1.4.1.41179.2.1
DirectTrust BA id-DirectTrust-Cat.(2) 1.3.6.1.4.1.41179.2.2
DirectTrust HE id-DirectTrust-Cat.(3) 1.3.6.1.4.1.41179.2.3
DirectTrust Patient id-DirectTrust-Cat.(4) 1.3.6.1.4.1.41179.2.4
DirectTrust NonDeclared id-DirectTrust-Cat.(5) 1.3.6.1.4.1.41179.2.5
id-DirectTrust-Dev id-DirectTrust.(3) 1.3.6.1.4.1.41179.3
DirectTrust Device id-DirectTrust-Dev.(1) 1.3.6.1.4.1.41179.3.1
id-DirectTrust-authLoAs id-DirectTrust.(6) 1.3.6.1.4.1.41179.6
DirectTrust Auth AAL 1 id-DirectTrust-auth-LoAs.(5) 1.3.6.1.4.1.41179.6.5
DirectTrust Auth AAL 2 id-DirectTrust-auth-LoAs.(6) 1.3.6.1.4.1.41179.6.6
DirectTrust Auth AAL 3 id-DirectTrust-auth-LoAs.(7) 1.3.6.1.4.1.41179.6.7
id-DirectTrust-Cont id-DirectTrust.(7) 1.3.6.1.4.1.41179.7
DirectTrust Content Commitment id-DirectTrust-Cont.(1) 1.3.6.1.4.1.41179.7.1";
let substitution = "\\3\\t\\2\\t\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}