# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*) ([\w\d\.\-\(\)]+) (\d(?:\.\d+){2,}$)"
test_str = ("id-DirectTrust. arc 1.3.6.1.4.1.41179\n"
"id-DirectTrustpolicies id-DirectTrust.(0) 1.3.6.1.4.1.41179.0\n"
"DirectTrust-CP 2.0 id-DirectTrustpolicies.(2.0) 1.3.6.1.4.1.41179.0.2.0\n"
"id-DirectTrust-LoAs id-DirectTrust.(1) 1.3.6.1.4.1.41179.1\n"
"DirectTrust ID LoA 1 id-DirectTrust-LoAs.(1) 1.3.6.1.4.1.41179.1.1\n"
"DirectTrust ID LoA 2 id-DirectTrust-LoAs.(2) 1.3.6.1.4.1.41179.1.2\n"
"DirectTrust ID LoA 3 id-DirectTrust-LoAs.(3) 1.3.6.1.4.1.41179.1.3\n"
"DirectTrust ID LoA 4 id-DirectTrust-LoAs.(4) 1.3.6.1.4.1.41179.1.4\n"
"DirectTrust ID IAL 1 id-DirectTrust-LoAs.(1) 1.3.6.1.4.1.41179.1.1\n"
"DirectTrust ID IAL 2 id-DirectTrust-LoAs.(5) 1.3.6.1.4.1.41179.1.5\n"
"DirectTrust ID IAL 3 id-DirectTrust-LoAs.(6) 1.3.6.1.4.1.41179.1.6\n"
"id-DirectTrust-Cat id-DirectTrust.(2) 1.3.6.1.4.1.41179.2\n"
"DirectTrust CE id-DirectTrust-Cat.(1) 1.3.6.1.4.1.41179.2.1\n"
"DirectTrust BA id-DirectTrust-Cat.(2) 1.3.6.1.4.1.41179.2.2\n"
"DirectTrust HE id-DirectTrust-Cat.(3) 1.3.6.1.4.1.41179.2.3\n"
"DirectTrust Patient id-DirectTrust-Cat.(4) 1.3.6.1.4.1.41179.2.4\n"
"DirectTrust NonDeclared id-DirectTrust-Cat.(5) 1.3.6.1.4.1.41179.2.5\n"
"id-DirectTrust-Dev id-DirectTrust.(3) 1.3.6.1.4.1.41179.3\n"
"DirectTrust Device id-DirectTrust-Dev.(1) 1.3.6.1.4.1.41179.3.1\n"
"id-DirectTrust-authLoAs id-DirectTrust.(6) 1.3.6.1.4.1.41179.6\n"
"DirectTrust Auth AAL 1 id-DirectTrust-auth-LoAs.(5) 1.3.6.1.4.1.41179.6.5\n"
"DirectTrust Auth AAL 2 id-DirectTrust-auth-LoAs.(6) 1.3.6.1.4.1.41179.6.6\n"
"DirectTrust Auth AAL 3 id-DirectTrust-auth-LoAs.(7) 1.3.6.1.4.1.41179.6.7\n"
"id-DirectTrust-Cont id-DirectTrust.(7) 1.3.6.1.4.1.41179.7\n"
"DirectTrust Content Commitment id-DirectTrust-Cont.(1) 1.3.6.1.4.1.41179.7.1")
subst = "\\3\\t\\2\\t\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.