re = /female.*?robot/
str = 'animatronic canine female five_nights_at_freddy\'s five_nights_at_freddy\'s_2 fox glowing glowing_eyes machine mammal mangle_(fnaf) o-w-l-y_(artist) robot video_games'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end