$re = '/female.*?robot/';
$str = 'animatronic canine female five_nights_at_freddy\'s five_nights_at_freddy\'s_2 fox glowing glowing_eyes machine mammal mangle_(fnaf) o-w-l-y_(artist) robot video_games';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);