package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`female.*?robot`)
var str = `animatronic canine female five_nights_at_freddy's five_nights_at_freddy's_2 fox glowing glowing_eyes machine mammal mangle_(fnaf) o-w-l-y_(artist) robot video_games`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}