// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z0-9_\-.]+)(?:\:([0-9]+))?(\/[^\?\s]*)?").unwrap();
let string = "website.host21.ru/contacts?p1=2&p2=3
website.host21.ru/contacts/
host1.host21.ru:80/contacts/
localhost:5372
baidu.c-_om
ekuiper_da
ekuiper_da:80/api
ekuiper:9081/a
ekuier:9081/api
localhost:9081
127.0.0.1:90/api
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}