import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z0-9_\\-.]+)(?:\\:([0-9]+))?(\\/[^\\?\\s]*)?";
final String string = "website.host21.ru/contacts?p1=2&p2=3\n"
+ "website.host21.ru/contacts/\n"
+ "host1.host21.ru:80/contacts/\n"
+ "localhost:5372\n"
+ "baidu.c-_om\n"
+ "ekuiper_da\n"
+ "ekuiper_da:80/api\n"
+ "ekuiper:9081/a\n"
+ "ekuier:9081/api\n"
+ "localhost:9081\n"
+ "127.0.0.1:90/api\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}