const regex = /^([a-z0-9_\-.]+)(?:\:([0-9]+))?(\/[^\?\s]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9_\\-.]+)(?:\\:([0-9]+))?(\\\/[^\\?\\s]*)?', 'gm')
const str = `website.host21.ru/contacts?p1=2&p2=3
website.host21.ru/contacts/
host1.host21.ru:80/contacts/
localhost:5372
baidu.c-_om
ekuiper_da
ekuiper_da:80/api
ekuiper:9081/a
ekuier:9081/api
localhost:9081
127.0.0.1:90/api
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}