use strict;
my $str = 'xn--4gbrim.xn--wgbh1c
中文域名.中国
😄❤️🌟.ws
example.com
xn--mgbah1a3hjkrd.com
🍕🏞️🎵.online
技术论坛.中国
www.nck.gg
www.www2.test.com
xn--80aaag1a8aj.xn
商业网站.中国';
my $regex = qr/^(?:[^:\/?#]+:)?(?:(?:\/\/)?(?:[^\s\/?#]+\.)+[^\s\/?#]+(?:\/[^\s"#]*)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}