package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:\/?#]+:)?(?:(?:\/\/)?(?:[^\s\/?#]+\.)+[^\s\/?#]+(?:\/[^\s"#]*)?)$`)
var str = `xn--4gbrim.xn--wgbh1c
中文域名.中国
😄❤️🌟.ws
example.com
xn--mgbah1a3hjkrd.com
🍕🏞️🎵.online
技术论坛.中国
www.nck.gg
www.www2.test.com
xn--80aaag1a8aj.xn
商业网站.中国`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}