import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^:\\/?#]+:)?(?:(?:\\/\\/)?(?:[^\\s\\/?#]+\\.)+[^\\s\\/?#]+(?:\\/[^\\s\"#]*)?)$";
final String string = "xn--4gbrim.xn--wgbh1c\n"
+ "中文域名.中国\n"
+ "😄❤️🌟.ws\n"
+ "example.com\n"
+ "xn--mgbah1a3hjkrd.com\n"
+ "🍕🏞️🎵.online\n"
+ "技术论坛.中国\n"
+ "www.nck.gg\n"
+ "www.www2.test.com\n"
+ "xn--80aaag1a8aj.xn\n"
+ "商业网站.中国";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}