# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"<tr[^>]*>\n"
r"[^<]*<td[^>]*>(?<No>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<ID>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Name>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Home_phone>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Work_phone>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Cell_phone>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Country>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>[^<]*<a[^>]*>(?<Email>[^<]*)<\/a[^>]*><\/td>\n"
r"[^<]*<td[^>]*>(?<Levels>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Rank>[^<]*)<\/td>\n"
r"[^<]*<td[^>]*>(?<Sponzor_ID>[^<]*)<\/td>")
test_str = ("\n"
" <!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
"<html xmlns=\"http://www.w3.org/1999/xhtml\">\n"
"<head>\n"
"<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" />\n"
"<title>PBC - New Distributor List</title>\n"
"<meta name=\"description\" content=\"Lifestyles PBC is an on-line tool to help our Distributors manage their business and achieve their goals.\" />\n"
"<meta name=\"keywords\" content=\"Lifestyles, Lifestyles International, Personal Business Center, PBC\"/>\n"
"<link href=\"css/en.css\" rel=\"stylesheet\" type=\"text/css\" />\n"
"</head>\n"
"<body bgcolor=\"#EAF4D1\" leftmargin=\"0\" topmargin=\"3\" marginwidth=\"0\" marginheight=\"0\">\n"
"<table border=\"0\" align=\"center\" cellpadding=\"1\" cellspacing=\"1\" bgcolor=\"#999999\">\n"
" <tr> <td height=\"33\" colspan=\"11\" align=\"center\" bgcolor=\"#FFFFFF\"><h2 style=\"margin: 10px\">New Distributor List</h2>\n"
" <p style=\"margin: 10px\">Month: Sep.17</p></td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#CCCCCC\"><strong>No.</strong></td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#CCCCCC\"><strong>ID</strong></td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#CCCCCC\"><strong>Name</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Home Phone</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Business Phone</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Cell Phone</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Country</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Email</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Levels</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Rank</strong></td>\n"
" <td align=\"center\" bgcolor=\"#CCCCCC\"><strong>Sponsor</strong></td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">1</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">98000274072</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">Jaroslava Adamcova</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">420 777642993</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Czech Republic</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"><a href=\"mailto:mrs.crazy@post.cz\">mrs.crazy@post.cz</a></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">19</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Distributor</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">80011630542</td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">2</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">98000274172</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">Lucie Hybsova</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">420 773252262</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Czech Republic</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"><a href=\"mailto:hybsovaluca@seznam.cz\">hybsovaluca@seznam.cz</a></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">19</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Distributor</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">80011630542</td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">3</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">98000274475</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">Miroslava Dobruska</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">420 739555554</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"> 123456789</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">602230645</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Czech Republic</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"><a href=\"mailto:dobruska.miroslava@seznam.cz\">dobruska.miroslava@seznam.cz</a></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">18</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Distributor</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">13980242</td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">4</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">98000274484</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">Dana Barochova</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">420 774312227</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Czech Republic</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"><a href=\"mailto:dbaro@seznam.cz\">dbaro@seznam.cz</a></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">20</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Distributor</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">98000203618</td>\n"
" </tr>\n"
" <tr>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">5</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">98000275105</td>\n"
" <td height=\"27\" align=\"center\" bgcolor=\"#FFFFFF\">Tibor Abel</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">420 777268915</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Czech Republic</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\"><a href=\"mailto:abeltibor@gmail.com\">abeltibor@gmail.com</a></td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">19</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">Distributor</td>\n"
" <td align=\"center\" bgcolor=\"#FFFFFF\">80011630542</td>\n"
" </tr>\n"
" </table>\n"
"</body>\n"
"</html>\n"
"<script>window.focus()</script>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.