#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<tr[^>]*>" & @CRLF & _
"[^<]*<td[^>]*>(?<No>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<ID>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Name>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Home_phone>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Work_phone>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Cell_phone>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Country>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>[^<]*<a[^>]*>(?<Email>[^<]*)<\/a[^>]*><\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Levels>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Rank>[^<]*)<\/td>" & @CRLF & _
"[^<]*<td[^>]*>(?<Sponzor_ID>[^<]*)<\/td>"
Local $sString = "" & @CRLF & _
" <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head>" & @CRLF & _
"<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />" & @CRLF & _
"<title>PBC - New Distributor List</title>" & @CRLF & _
"<meta name="description" content="Lifestyles PBC is an on-line tool to help our Distributors manage their business and achieve their goals." />" & @CRLF & _
"<meta name="keywords" content="Lifestyles, Lifestyles International, Personal Business Center, PBC"/>" & @CRLF & _
"<link href="css/en.css" rel="stylesheet" type="text/css" />" & @CRLF & _
"</head>" & @CRLF & _
"<body bgcolor="#EAF4D1" leftmargin="0" topmargin="3" marginwidth="0" marginheight="0">" & @CRLF & _
"<table border="0" align="center" cellpadding="1" cellspacing="1" bgcolor="#999999">" & @CRLF & _
" <tr> <td height="33" colspan="11" align="center" bgcolor="#FFFFFF"><h2 style="margin: 10px">New Distributor List</h2>" & @CRLF & _
" <p style="margin: 10px">Month: Sep.17</p></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#CCCCCC"><strong>No.</strong></td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#CCCCCC"><strong>ID</strong></td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#CCCCCC"><strong>Name</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Home Phone</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Business Phone</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Cell Phone</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Country</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Email</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Levels</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Rank</strong></td>" & @CRLF & _
" <td align="center" bgcolor="#CCCCCC"><strong>Sponsor</strong></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">1</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">98000274072</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">Jaroslava Adamcova</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">420 777642993</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Czech Republic</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"><a href="mailto:mrs.crazy@post.cz">mrs.crazy@post.cz</a></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">19</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Distributor</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">80011630542</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">2</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">98000274172</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">Lucie Hybsova</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">420 773252262</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Czech Republic</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"><a href="mailto:hybsovaluca@seznam.cz">hybsovaluca@seznam.cz</a></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">19</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Distributor</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">80011630542</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">3</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">98000274475</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">Miroslava Dobruska</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">420 739555554</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"> 123456789</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">602230645</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Czech Republic</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"><a href="mailto:dobruska.miroslava@seznam.cz">dobruska.miroslava@seznam.cz</a></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">18</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Distributor</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">13980242</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">4</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">98000274484</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">Dana Barochova</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">420 774312227</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Czech Republic</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"><a href="mailto:dbaro@seznam.cz">dbaro@seznam.cz</a></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">20</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Distributor</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">98000203618</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">5</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">98000275105</td>" & @CRLF & _
" <td height="27" align="center" bgcolor="#FFFFFF">Tibor Abel</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">420 777268915</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Czech Republic</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF"><a href="mailto:abeltibor@gmail.com">abeltibor@gmail.com</a></td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">19</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">Distributor</td>" & @CRLF & _
" <td align="center" bgcolor="#FFFFFF">80011630542</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
"<script>window.focus()</script>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")