use strict;
my $str = '
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>PBC - New Distributor List</title>
<meta name="description" content="Lifestyles PBC is an on-line tool to help our Distributors manage their business and achieve their goals." />
<meta name="keywords" content="Lifestyles, Lifestyles International, Personal Business Center, PBC"/>
<link href="css/en.css" rel="stylesheet" type="text/css" />
</head>
<body bgcolor="#EAF4D1" leftmargin="0" topmargin="3" marginwidth="0" marginheight="0">
<table border="0" align="center" cellpadding="1" cellspacing="1" bgcolor="#999999">
<tr> <td height="33" colspan="11" align="center" bgcolor="#FFFFFF"><h2 style="margin: 10px">New Distributor List</h2>
<p style="margin: 10px">Month: Sep.17</p></td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#CCCCCC"><strong>No.</strong></td>
<td height="27" align="center" bgcolor="#CCCCCC"><strong>ID</strong></td>
<td height="27" align="center" bgcolor="#CCCCCC"><strong>Name</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Home Phone</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Business Phone</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Cell Phone</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Country</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Email</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Levels</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Rank</strong></td>
<td align="center" bgcolor="#CCCCCC"><strong>Sponsor</strong></td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#FFFFFF">1</td>
<td height="27" align="center" bgcolor="#FFFFFF">98000274072</td>
<td height="27" align="center" bgcolor="#FFFFFF">Jaroslava Adamcova</td>
<td align="center" bgcolor="#FFFFFF">420 777642993</td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF">Czech Republic</td>
<td align="center" bgcolor="#FFFFFF"><a href="mailto:mrs.crazy@post.cz">mrs.crazy@post.cz</a></td>
<td align="center" bgcolor="#FFFFFF">19</td>
<td align="center" bgcolor="#FFFFFF">Distributor</td>
<td align="center" bgcolor="#FFFFFF">80011630542</td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#FFFFFF">2</td>
<td height="27" align="center" bgcolor="#FFFFFF">98000274172</td>
<td height="27" align="center" bgcolor="#FFFFFF">Lucie Hybsova</td>
<td align="center" bgcolor="#FFFFFF">420 773252262</td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF">Czech Republic</td>
<td align="center" bgcolor="#FFFFFF"><a href="mailto:hybsovaluca@seznam.cz">hybsovaluca@seznam.cz</a></td>
<td align="center" bgcolor="#FFFFFF">19</td>
<td align="center" bgcolor="#FFFFFF">Distributor</td>
<td align="center" bgcolor="#FFFFFF">80011630542</td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#FFFFFF">3</td>
<td height="27" align="center" bgcolor="#FFFFFF">98000274475</td>
<td height="27" align="center" bgcolor="#FFFFFF">Miroslava Dobruska</td>
<td align="center" bgcolor="#FFFFFF">420 739555554</td>
<td align="center" bgcolor="#FFFFFF"> 123456789</td>
<td align="center" bgcolor="#FFFFFF">602230645</td>
<td align="center" bgcolor="#FFFFFF">Czech Republic</td>
<td align="center" bgcolor="#FFFFFF"><a href="mailto:dobruska.miroslava@seznam.cz">dobruska.miroslava@seznam.cz</a></td>
<td align="center" bgcolor="#FFFFFF">18</td>
<td align="center" bgcolor="#FFFFFF">Distributor</td>
<td align="center" bgcolor="#FFFFFF">13980242</td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#FFFFFF">4</td>
<td height="27" align="center" bgcolor="#FFFFFF">98000274484</td>
<td height="27" align="center" bgcolor="#FFFFFF">Dana Barochova</td>
<td align="center" bgcolor="#FFFFFF">420 774312227</td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF">Czech Republic</td>
<td align="center" bgcolor="#FFFFFF"><a href="mailto:dbaro@seznam.cz">dbaro@seznam.cz</a></td>
<td align="center" bgcolor="#FFFFFF">20</td>
<td align="center" bgcolor="#FFFFFF">Distributor</td>
<td align="center" bgcolor="#FFFFFF">98000203618</td>
</tr>
<tr>
<td height="27" align="center" bgcolor="#FFFFFF">5</td>
<td height="27" align="center" bgcolor="#FFFFFF">98000275105</td>
<td height="27" align="center" bgcolor="#FFFFFF">Tibor Abel</td>
<td align="center" bgcolor="#FFFFFF">420 777268915</td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF"></td>
<td align="center" bgcolor="#FFFFFF">Czech Republic</td>
<td align="center" bgcolor="#FFFFFF"><a href="mailto:abeltibor@gmail.com">abeltibor@gmail.com</a></td>
<td align="center" bgcolor="#FFFFFF">19</td>
<td align="center" bgcolor="#FFFFFF">Distributor</td>
<td align="center" bgcolor="#FFFFFF">80011630542</td>
</tr>
</table>
</body>
</html>
<script>window.focus()</script>
';
my $regex = qr/<tr[^>]*>
[^<]*<td[^>]*>(?<No>[^<]*)<\/td>
[^<]*<td[^>]*>(?<ID>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Name>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Home_phone>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Work_phone>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Cell_phone>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Country>[^<]*)<\/td>
[^<]*<td[^>]*>[^<]*<a[^>]*>(?<Email>[^<]*)<\/a[^>]*><\/td>
[^<]*<td[^>]*>(?<Levels>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Rank>[^<]*)<\/td>
[^<]*<td[^>]*>(?<Sponzor_ID>[^<]*)<\/td>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}