re = /import\s+([^()]+?)\s+from\s+(['"])@(system|service)([^\/()]+?)\2/
str = 'import router from \'@system.router1\'
import router from @system.router2
import router from "@system.router3\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end