$re = '/import\s+([^()]+?)\s+from\s+([\'"])@(system|service)([^\/()]+?)\2/';
$str = 'import router from \'@system.router1\'
import router from @system.router2
import router from "@system.router3\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);