using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import\s+([^()]+?)\s+from\s+(['""])@(system|service)([^\/()]+?)\2";
string input = @"import router from '@system.router1'
import router from @system.router2
import router from ""@system.router3'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}