$re = '/ספר\s(מדע|אהבה|זמנים)/m';
$str = 'ספר מדע
ספר אהבה
ספר זמנים';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);