package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ספר\s(מדע|אהבה|זמנים)`)
var str = `ספר מדע
ספר אהבה
ספר זמנים`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}