using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ספר\s(מדע|אהבה|זמנים)";
string input = @"ספר מדע
ספר אהבה
ספר זמנים";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}